Discussion:
Build failure after upgrading from 0.13.0 to 0.14.1
(too old to reply)
Robert Munteanu
2012-03-04 22:59:40 UTC
Permalink
Hi,

I have a project which I build using Tycho 0.13.0 . After upgrading to
Tycho 0.14.1 , the build fails with:

[ERROR] Cannot resolve project dependencies:
[ERROR] Software being installed:
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR] Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
[ERROR] Cannot satisfy dependency:
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]

I've tried ignoring optional dependencies with

<dependency-resolution>
<optionalDependencies>ignore</optionalDependencies>
</dependency-resolution>

but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/

The full resolver message is below

"No solution found because the problem is unsatisfiable.":
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]

Any hints on how to fix the build for 0.14.1 would be appreciated.

Thanks,

Robert
--
Sent from my (old) computer
Igor Fedorenko
2012-03-05 00:40:56 UTC
Permalink
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?

--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR] Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
<dependency-resolution>
<optionalDependencies>ignore</optionalDependencies>
</dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
Robert Munteanu
2012-03-05 14:02:54 UTC
Permalink
Hi,

According to https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get

<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>

Also in the target file I have set

<targetJRE path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>

I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.

Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR]   Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
  <dependency-resolution>
    <optionalDependencies>ignore</optionalDependencies>
  </dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Sent from my (old) computer
Igor Fedorenko
2012-03-05 16:08:51 UTC
Permalink
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.

--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR] Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
<dependency-resolution>
<optionalDependencies>ignore</optionalDependencies>
</dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Robert Munteanu
2012-03-05 17:20:05 UTC
Permalink
Should I file a bug? Do you have any suggestions for debugging?

Robert
Post by Igor Fedorenko
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.
--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR]   Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
  <dependency-resolution>
    <optionalDependencies>ignore</optionalDependencies>
  </dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Sent from my (old) computer
Igor Fedorenko
2012-03-05 17:33:40 UTC
Permalink
Feel free to file a bug report, but I can't promise we'll be able to
look at it any time soon.

In Tycho 0.15, you can enable detailed resolver debug log with "-X
-Dtycho.debug.resolver=<artifact-id>" and this will print all
installable units it gets from repositories, so you can double-check if
this matches what you expect your repositories have.

Beyond that, you really need to run Tycho through debugger and see where
the problem occurs.

--
Regards,
Igor
Post by Robert Munteanu
Should I file a bug? Do you have any suggestions for debugging?
Robert
Post by Igor Fedorenko
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.
--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR] Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
<dependency-resolution>
<optionalDependencies>ignore</optionalDependencies>
</dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Robert Munteanu
2012-03-10 11:22:59 UTC
Permalink
I've discovered that by excluding my eclemma build from the reactor I
am able to complete the build.

That bundle's manifest is basic:

Manifest-Version: 1.0
Export-Package: com.vladium.emma.rt
Bundle-Vendor: Mountainminds GmbH & Co. KG
Fragment-Host: org.eclipse.osgi;bundle-version="[3.5.0,4.0.0)"
Bundle-ClassPath: .,emma.jar
Bundle-Version: 3.9.0.qualifier
Bundle-Name: Emma Runtime Instrumentation for Equinox
Bundle-ManifestVersion: 2
Bundle-SymbolicName: com.itsolut.mantis.eclemma
Bundle-RequiredExecutionEnvironment: J2SE-1.4,OSGi/Minimum-1.1

You can see the rest of the project at
https://github.com/Mylyn-Mantis/mylyn-mantis/tree/master/com.itsolut.mantis.eclemma
.

Any ideas on why this would fail the build? Alternatively if anyone
can point me to a eclemma bundle which works with Tycho 0.14.1 I'll
gladly take that as well.

Robert
Post by Igor Fedorenko
Feel free to file a bug report, but I can't promise we'll be able to
look at it any time soon.
In Tycho 0.15, you can enable detailed resolver debug log with "-X
-Dtycho.debug.resolver=<artifact-id>" and this will print all
installable units it gets from repositories, so you can double-check if
this matches what you expect your repositories have.
Beyond that, you really need to run Tycho through debugger and see where
the problem occurs.
--
Regards,
Igor
Post by Robert Munteanu
Should I file a bug? Do you have any suggestions for debugging?
Robert
Post by Igor Fedorenko
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.
--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR]   Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
  <dependency-resolution>
    <optionalDependencies>ignore</optionalDependencies>
  </dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Sent from my (old) computer
Igor Fedorenko
2012-03-10 13:50:33 UTC
Permalink
are you sure that all missing imported packages are provided by either
J2SE-1.4 or OSGi/Minimum-1.1 profiles?

--
Regards,
Igor
Post by Robert Munteanu
I've discovered that by excluding my eclemma build from the reactor I
am able to complete the build.
Manifest-Version: 1.0
Export-Package: com.vladium.emma.rt
Bundle-Vendor: Mountainminds GmbH& Co. KG
Fragment-Host: org.eclipse.osgi;bundle-version="[3.5.0,4.0.0)"
Bundle-ClassPath: .,emma.jar
Bundle-Version: 3.9.0.qualifier
Bundle-Name: Emma Runtime Instrumentation for Equinox
Bundle-ManifestVersion: 2
Bundle-SymbolicName: com.itsolut.mantis.eclemma
Bundle-RequiredExecutionEnvironment: J2SE-1.4,OSGi/Minimum-1.1
You can see the rest of the project at
https://github.com/Mylyn-Mantis/mylyn-mantis/tree/master/com.itsolut.mantis.eclemma
.
Any ideas on why this would fail the build? Alternatively if anyone
can point me to a eclemma bundle which works with Tycho 0.14.1 I'll
gladly take that as well.
Robert
Post by Igor Fedorenko
Feel free to file a bug report, but I can't promise we'll be able to
look at it any time soon.
In Tycho 0.15, you can enable detailed resolver debug log with "-X
-Dtycho.debug.resolver=<artifact-id>" and this will print all
installable units it gets from repositories, so you can double-check if
this matches what you expect your repositories have.
Beyond that, you really need to run Tycho through debugger and see where
the problem occurs.
--
Regards,
Igor
Post by Robert Munteanu
Should I file a bug? Do you have any suggestions for debugging?
Robert
Post by Igor Fedorenko
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.
--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR] Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
<dependency-resolution>
<optionalDependencies>ignore</optionalDependencies>
</dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Robert Munteanu
2012-03-11 11:32:42 UTC
Permalink
Changing the BREE to J2SE-1.5 has fixed the build. I'm not really sure
why and why it started failing now, but I'm happy that it works.

Thanks,

Robert
Post by Igor Fedorenko
are you sure that all missing imported packages are provided by either
J2SE-1.4 or OSGi/Minimum-1.1 profiles?
--
Regards,
Igor
Post by Robert Munteanu
I've discovered that by excluding my eclemma build from the reactor I
am able to complete the build.
Manifest-Version: 1.0
Export-Package: com.vladium.emma.rt
Bundle-Vendor: Mountainminds GmbH&  Co. KG
Fragment-Host: org.eclipse.osgi;bundle-version="[3.5.0,4.0.0)"
Bundle-ClassPath: .,emma.jar
Bundle-Version: 3.9.0.qualifier
Bundle-Name: Emma Runtime Instrumentation for Equinox
Bundle-ManifestVersion: 2
Bundle-SymbolicName: com.itsolut.mantis.eclemma
Bundle-RequiredExecutionEnvironment: J2SE-1.4,OSGi/Minimum-1.1
You can see the rest of the project at
https://github.com/Mylyn-Mantis/mylyn-mantis/tree/master/com.itsolut.mantis.eclemma
.
Any ideas on why this would fail the build? Alternatively if anyone
can point me to a eclemma bundle which works with Tycho 0.14.1 I'll
gladly take that as well.
Robert
Post by Igor Fedorenko
Feel free to file a bug report, but I can't promise we'll be able to
look at it any time soon.
In Tycho 0.15, you can enable detailed resolver debug log with "-X
-Dtycho.debug.resolver=<artifact-id>" and this will print all
installable units it gets from repositories, so you can double-check if
this matches what you expect your repositories have.
Beyond that, you really need to run Tycho through debugger and see where
the problem occurs.
--
Regards,
Igor
Post by Robert Munteanu
Should I file a bug? Do you have any suggestions for debugging?
Robert
Post by Igor Fedorenko
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.
--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR]   Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle
org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
  <dependency-resolution>
    <optionalDependencies>ignore</optionalDependencies>
  </dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package
javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Sent from my (old) computer
Cristiano Gavião
2012-03-05 20:40:01 UTC
Permalink
Robert,

I had the same kind of issue. It was related to classes (javax.*,
com.sun.*) that already exists on jdk.

I've resolved my problem creating a fragment bundle...
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: com.c4biz.osgiutils.jdk.deps
Bundle-Version: 0.0.8.qualifier
Bundle-Vendor: %providerName
Fragment-Host: org.eclipse.osgi;extension:=framework
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: com.sun.codemodel,
com.sun.msv.datatype,
com.sun.msv.datatype.xsd,
com.sun.tools.xjc,
com.sun.tools.xjc.model,
com.sun.tools.xjc.outline,
org.relaxng.datatype,
org.ietf.jgss,
sun.misc,
sun.reflect,
javax.imageio,
javax.imageio.stream,
javax.net,
javax.net.ssl,
javax.security.cert,
javax.security.auth,
javax.security.auth.login,
javax.security.auth.spi,
javax.security.auth.callback,
javax.security.auth.x500,
javax.crypt,
javax.crypto.spec,
javax.crypto,
javax.naming,
javax.naming.ldap,
javax.naming.directory,
javax.naming.spi,
javax.sql,
javax.swing,
javax.swing.plaf,
javax.sql,
javax.transaction,
javax.transaction.xa
add this project as a module in the reactor and try to build your
project with tycho 0.14.1 again...

let me know if it worked for you...

regards,

Cristiano
Should I file a bug? Do you have any suggestions for debugging?
Robert
Post by Igor Fedorenko
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.
--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR] Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR] Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
<dependency-resolution>
<optionalDependencies>ignore</optionalDependencies>
</dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Robert Munteanu
2012-03-10 10:58:39 UTC
Permalink
Cristiano, thanks for your help. It seems that we have hit different
problems. I've added a new tycho module and put it first in the module
list. The pom.xml is quite basic:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>

<parent>
<groupId>com.itsolut.mantis</groupId>
<artifactId>com.itsolut.mantis.parent</artifactId>
<version>3.9.0-SNAPSHOT</version>
<relativePath>../pom.xml</relativePath>
</parent>

<artifactId>com.itsolut.mantis.jdk</artifactId>
<packaging>eclipse-plugin</packaging>
<name>Mylyn Mantis Connector: JDK bundle</name>
</project>

And the MANIFEST.MF file is very similar to the one you pasted below.

The build still fails with the same unresolved dependency: javax.crypto

Robert
Post by Cristiano Gavião
Robert,
I had the same kind of issue. It was related to classes (javax.*, com.sun.*)
that already exists on jdk.
I've resolved my problem creating a fragment bundle...
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: com.c4biz.osgiutils.jdk.deps
Bundle-Version: 0.0.8.qualifier
Bundle-Vendor: %providerName
Fragment-Host: org.eclipse.osgi;extension:=framework
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: com.sun.codemodel,
 com.sun.msv.datatype,
 com.sun.msv.datatype.xsd,
 com.sun.tools.xjc,
 com.sun.tools.xjc.model,
 com.sun.tools.xjc.outline,
 org.relaxng.datatype,
 org.ietf.jgss,
 sun.misc,
 sun.reflect,
 javax.imageio,
 javax.imageio.stream,
 javax.net,
 javax.net.ssl,
 javax.security.cert,
 javax.security.auth,
 javax.security.auth.login,
 javax.security.auth.spi,
 javax.security.auth.callback,
 javax.security.auth.x500,
 javax.crypt,
 javax.crypto.spec,
 javax.crypto,
 javax.naming,
 javax.naming.ldap,
 javax.naming.directory,
 javax.naming.spi,
 javax.sql,
 javax.swing,
 javax.swing.plaf,
 javax.sql,
 javax.transaction,
 javax.transaction.xa
add this project as a module in the reactor and try to build your project
with tycho 0.14.1 again...
let me know if it worked for you...
regards,
Cristiano
Should I file a bug? Do you have any suggestions for debugging?
Robert
Post by Igor Fedorenko
I am not sure what's going on, to be honest. The project specifies
J2SE-1.5 and all missing packages should be available either from JRE or
from Orbit.
--
Regards,
Igor
Post by Robert Munteanu
Hi,
According to
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/com.itsolut.mantis.core/.classpath
I get
<classpathentry kind="con"
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
Also in the target file I have set
<targetJRE
path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
I would expect these packages to be provided by the JRE . I don't
directly require/import them , but they are pulled in transitively.
Robert
Post by Igor Fedorenko
What is Bundle-RequiredExecutionEnvironment of your project? Is
javax.net.ssl and other missing packages expected to come from JRE or
provided by a thirdparty bundle?
--
Regards,
Igor
Post by Robert Munteanu
Hi,
I have a project which I build using Tycho 0.13.0 . After upgrading to
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100
[ERROR]   Missing requirement: org.eclipse.equinox.security
1.0.100.v20090520-1800 requires 'package javax.crypto 0.0.0' but it
could not be found
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.0.I20090522-1010 depends on: bundle org.eclipse.equinox.security
[1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.core.net
1.2.1.r35x_20090812-1200 depends on: bundle
org.eclipse.equinox.security [1.0.0,2.0.0)
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.commons.net
3.6.0.v20110608-1400 depends on: bundle org.eclipse.core.net 0.0.0
[ERROR]   Cannot satisfy dependency: org.eclipse.mylyn.discovery.core
3.6.1.v20110817-0100 depends on: bundle org.eclipse.mylyn.commons.net
3.1.0
org.eclipse.mylyn_feature.feature.group 3.6.5.v20120215-0100 depends
on: org.eclipse.mylyn.discovery.core [3.6.1.v20110817-0100]
I've tried ignoring optional dependencies with
  <dependency-resolution>
    <optionalDependencies>ignore</optionalDependencies>
  </dependency-resolution>
but that changed nothing. I've also bumped up my Orbit and Mylyn
version, with the same result. Probably the target resolution takes
into account more dependencies, but I'm not sure where to start
looking. My target file is found at
https://github.com/Mylyn-Mantis/mylyn-mantis/blob/master/mantis.target
and the project itself at
https://github.com/Mylyn-Mantis/mylyn-mantis/
The full resolver message is below
["Unable to satisfy dependency from javax.activation
1.1.0.v201105071233 to package javax.imageio 0.0.0.", "Unable to
satisfy dependency from javax.activation 1.1.0.v201105071233 to
package javax.imageio.metadata 0.0.0.", "Unable to satisfy dependency
from javax.mail 1.4.0.v201005080615 to package javax.net.ssl 0.0.0.",
"Unable to satisfy dependency from
org.eclipse.ecf.provider.filetransfer.ssl 1.0.0.v20090831-1906 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.eclipse.ecf.ssl 1.0.0.v20090831-1906 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.callback 0.0.0.", "Unable to satisfy dependency
from org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.login 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security 1.0.100.v20090520-1800 to package
javax.security.auth.spi 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.crypto.spec 0.0.0.", "Unable to satisfy dependency from
org.eclipse.equinox.security.ui 1.0.100.v20090520-1800 to package
javax.security.auth.x500 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.11.v200806031610 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty
5.1.11.v200806031610 to package javax.security.cert 0.0.0.", "Unable
to satisfy dependency from org.mortbay.jetty 5.1.14.v200806031611 to
package javax.net.ssl 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty 5.1.14.v200806031611 to package javax.security.cert
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.7.v200806031612 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.7.v200806031612
to package javax.security.cert 0.0.0.", "Unable to satisfy dependency
from org.mortbay.jetty.server 6.1.15.v200905151201 to package
javax.security.cert 0.0.0.", "Unable to satisfy dependency from
org.mortbay.jetty.server 6.1.15.v200905151201 to package javax.net.ssl
0.0.0.", "Unable to satisfy dependency from org.mortbay.jetty.server
6.1.23.v201012071420 to package javax.net.ssl 0.0.0.", "Unable to
satisfy dependency from org.mortbay.jetty.server 6.1.23.v201012071420
to package javax.security.cert 0.0.0.", "No solution found because the
problem is unsatisfiable."]
Any hints on how to fix the build for 0.14.1 would be appreciated.
Thanks,
Robert
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Sent from my (old) computer
Continue reading on narkive:
Loading...