Discussion:
Estimated release date of 0.21.0?
(too old to reply)
Marc-André Laperle
2014-04-15 14:34:11 UTC
Permalink
Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug
431793 <https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this
release planned before the Luna release? We would like to build our
project with a released version of Tycho in time for Luna so it would be
good to know.

Regards,
Marc-Andre
Sievers, Jan
2014-04-16 07:25:22 UTC
Permalink
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
Doug Schaefer
2014-04-16 14:24:32 UTC
Permalink
Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
Sievers, Jan
2014-04-17 07:03:38 UTC
Permalink
both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by default.

You can configure tycho-compiler-plugin to use a custom JDT compiler version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308

Best Regards,
Jan

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
Doug Schaefer
2014-04-17 13:30:42 UTC
Permalink
Thanks Jan, I've been configuring the compiler and it's working well. So I can assume that 21's move to Luna JDT likely won't happen until Luna is released? Or will it be sooner?

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Thursday, April 17, 2014 3:03 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by default.

You can configure tycho-compiler-plugin to use a custom JDT compiler version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308

Best Regards,
Jan

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
Sievers, Jan
2014-04-17 14:46:16 UTC
Permalink
0.21.0 is likely to happen shortly after Luna.

Best Regards,
Jan

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Donnerstag, 17. April 2014 15:31
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Thanks Jan, I've been configuring the compiler and it's working well. So I can assume that 21's move to Luna JDT likely won't happen until Luna is released? Or will it be sooner?

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Thursday, April 17, 2014 3:03 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by default.

You can configure tycho-compiler-plugin to use a custom JDT compiler version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308

Best Regards,
Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
Justin Georgeson
2014-04-17 17:09:02 UTC
Permalink
Is there a pluginRepository where we can get the Kepler feature patch version of JDT (3.9.50.v20140371-1741)?

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Sievers, Jan
Sent: Thursday, April 17, 2014 2:04 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by default.

You can configure tycho-compiler-plugin to use a custom JDT compiler version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308

Best Regards,
Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre

----------------------------------------------------------------------
This e-mail, including any attached files, may contain confidential and privileged information for the sole use of the intended recipient. Any review, use, distribution, or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive information for the intended recipient), please contact the sender by reply e-mail and delete all copies of this message.
David M Williams
2014-04-17 18:07:37 UTC
Permalink
3.10.0.v20140316-0146 is equivalent and was explicitly decided not to put
"patch version" in eclipse-staging (bug 430549) since we assumed it'd be
"out of date" soon, with no maintenance planed, as improvements and fixes
made would be on main (Luna) stream. In fact, for almost any purpose, I'd
recommend the latest (as indicated in Jan's link):

<cbi-jdt-repo.url>
https://repo.eclipse.org/content/repositories/eclipse-staging/
</cbi-jdt-repo.url>
<cbi-jdt-version>3.10.0.v20140408-1345</cbi-jdt-version>

[And, keep in mind, neither of these are "released" in normal sense of the
word, and will be going away, some day.]






From: Justin Georgeson <***@lgc.com>
To: Tycho user list <tycho-***@eclipse.org>,
Date: 04/17/2014 01:09 PM
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
Sent by: tycho-user-***@eclipse.org



Is there a pluginRepository where we can get the Kepler feature patch
version of JDT (3.9.50.v20140371-1741)?

From: tycho-user-***@eclipse.org [
mailto:tycho-user-***@eclipse.org] On Behalf Of Sievers, Jan
Sent: Thursday, April 17, 2014 2:04 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by
default.

You can configure tycho-compiler-plugin to use a custom JDT compiler
version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308


Best Regards,
Jan

From: tycho-user-***@eclipse.org [
mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't
seem to have the latest compiler in it. Or am I wrong on that? I'm writing
a tutorial on JavaFX in Java 8 and would like to show a magic free way of
building.

Thanks,
Doug


From: tycho-user-***@eclipse.org [tycho-user-***@eclipse.org] on
behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want
an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org [
mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug
431793. Is this release planned before the Luna release? We would like to
build our project with a released version of Tycho in time for Luna so it
would be good to know.

Regards,
Marc-Andre
This e-mail, including any attached files, may contain confidential and
privileged information for the sole use of the intended recipient. Any
review, use, distribution, or disclosure by others is strictly prohibited.
If you are not the intended recipient (or authorized to receive
information for the intended recipient), please contact the sender by
reply e-mail and delete all copies of this message.
Doug Schaefer
2014-04-17 18:45:16 UTC
Permalink
I am talking about the SNAPSHOT which also isn't a "release", so that's not a problem. BTW, I'm using this with 0.20.0 and it's working well. It's an older JDT build, but it's a pain in the behind to keep it up to date, which is why I ask when the Luna JDT will finally make it into one of the SNAPSHOTs:


<pluginRepositories>

<pluginRepository>

<id>cbi-jdt</id>

<url>https://repo.eclipse.org/content/repositories/eclipse-staging</url>

</pluginRepository>

</pluginRepositories>


<build>

<plugins>

<plugin>

<groupId>org.eclipse.tycho</groupId>

<artifactId>tycho-compiler-plugin</artifactId>

<version>${tycho.version}</version>

<dependencies>

<dependency>

<groupId>org.eclipse.jdt</groupId>

<artifactId>org.eclipse.jdt.core</artifactId>

<version>3.10.0.v20140316-0146</version>

</dependency>

</dependencies>

</plugin>

...

Doug.

________________________________
From: tycho-user-***@eclipse.org [tycho-user-***@eclipse.org] on behalf of David M Williams [***@us.ibm.com]
Sent: Thursday, April 17, 2014 2:07 PM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

3.10.0.v20140316-0146 is equivalent and was explicitly decided not to put "patch version" in eclipse-staging (bug 430549<https://bugs.eclipse.org/bugs/show_bug.cgi?id=430549>) since we assumed it'd be "out of date" soon, with no maintenance planed, as improvements and fixes made would be on main (Luna) stream. In fact, for almost any purpose, I'd recommend the latest (as indicated in Jan's link):

<cbi-jdt-repo.url>https://repo.eclipse.org/content/repositories/eclipse-staging/</cbi-jdt-repo.url>
<cbi-jdt-version>3.10.0.v20140408-1345</cbi-jdt-version>

[And, keep in mind, neither of these are "released" in normal sense of the word, and will be going away, some day.]






From: Justin Georgeson <***@lgc.com>
To: Tycho user list <tycho-***@eclipse.org>,
Date: 04/17/2014 01:09 PM
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
Sent by: tycho-user-***@eclipse.org
________________________________



Is there a pluginRepository where we can get the Kepler feature patch version of JDT (3.9.50.v20140371-1741)?

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Sievers, Jan
Sent: Thursday, April 17, 2014 2:04 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by default.

You can configure tycho-compiler-plugin to use a custom JDT compiler version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308

Best Regards,
Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
Justin Georgeson
2014-04-17 21:03:04 UTC
Permalink
Thanks. Wasn't sure if you could mix the 3.10 JDT with an otherwise Kepler platform but will move forward with it.

With Tycho 0.20.0, JDK 1.8.0, and JDT 3.10 I'm getting an NPE from maven trying to resolve project dependencies of an eclipse-plugin project for a platform fragment bundle, but not all of the platform fragment bundle projects so it's probably something on my end in that one project.

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of David M Williams
Sent: Thursday, April 17, 2014 1:08 PM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

3.10.0.v20140316-0146 is equivalent and was explicitly decided not to put "patch version" in eclipse-staging (bug 430549<https://bugs.eclipse.org/bugs/show_bug.cgi?id=430549>) since we assumed it'd be "out of date" soon, with no maintenance planed, as improvements and fixes made would be on main (Luna) stream. In fact, for almost any purpose, I'd recommend the latest (as indicated in Jan's link):

<cbi-jdt-repo.url>https://repo.eclipse.org/content/repositories/eclipse-staging/</cbi-jdt-repo.url>
<cbi-jdt-version>3.10.0.v20140408-1345</cbi-jdt-version>

[And, keep in mind, neither of these are "released" in normal sense of the word, and will be going away, some day.]






From: Justin Georgeson <***@lgc.com<mailto:***@lgc.com>>
To: Tycho user list <tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>>,
Date: 04/17/2014 01:09 PM
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
Sent by: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org>
________________________________



Is there a pluginRepository where we can get the Kepler feature patch version of JDT (3.9.50.v20140371-1741)?

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Sievers, Jan
Sent: Thursday, April 17, 2014 2:04 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by default.

You can configure tycho-compiler-plugin to use a custom JDT compiler version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308

Best Regards,
Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
David M Williams
2014-04-17 22:36:46 UTC
Permalink
> Thanks. Wasn’t sure if you could mix the 3.10 JDT with an otherwise
> Kepler platform but will move forward with it.

To be sure we are talking about the same thing ... my reply was meant as
"what to use as the compiler" ... if you are looking at something to _
distribute _ then you are right, you shouldn't mix, and you can use the
version in the patch itself, which you can get from repo at
.../eclipse/updates/4.3-P-builds/

> With Tycho 0.20.0, JDK 1.8.0, and JDT 3.10 I’m getting an NPE from
> maven trying to resolve project dependencies of an eclipse-plugin
> project for a platform fragment bundle, but not all of the platform
> fragment bundle projects so it’s probably something on my end in
> that one project.

To cover the basics ... if you are re-compiling platform projects, I'm
assuming you know that you'll need to define a "toolchains.xml" file and
"useJDK" ... as mostly described in
https://wiki.eclipse.org/Platform-releng/Platform_Build#Using_BREE_Libs

HTH




From: Justin Georgeson <***@lgc.com>
To: Tycho user list <tycho-***@eclipse.org>,
Date: 04/17/2014 05:04 PM
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
Sent by: tycho-user-***@eclipse.org



Thanks. Wasn’t sure if you could mix the 3.10 JDT with an otherwise Kepler
platform but will move forward with it.

With Tycho 0.20.0, JDK 1.8.0, and JDT 3.10 I’m getting an NPE from maven
trying to resolve project dependencies of an eclipse-plugin project for a
platform fragment bundle, but not all of the platform fragment bundle
projects so it’s probably something on my end in that one project.

From: tycho-user-***@eclipse.org [
mailto:tycho-user-***@eclipse.org] On Behalf Of David M Williams
Sent: Thursday, April 17, 2014 1:08 PM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

3.10.0.v20140316-0146 is equivalent and was explicitly decided not to put
"patch version" in eclipse-staging (bug 430549) since we assumed it'd be
"out of date" soon, with no maintenance planed, as improvements and fixes
made would be on main (Luna) stream. In fact, for almost any purpose, I'd
recommend the latest (as indicated in Jan's link):

<cbi-jdt-repo.url>
https://repo.eclipse.org/content/repositories/eclipse-staging/
</cbi-jdt-repo.url>
<cbi-jdt-version>3.10.0.v20140408-1345</cbi-jdt-version>

[And, keep in mind, neither of these are "released" in normal sense of the
word, and will be going away, some day.]






From: Justin Georgeson <***@lgc.com>
To: Tycho user list <tycho-***@eclipse.org>,
Date: 04/17/2014 01:09 PM
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
Sent by: tycho-user-***@eclipse.org




Is there a pluginRepository where we can get the Kepler feature patch
version of JDT (3.9.50.v20140371-1741)?

From: tycho-user-***@eclipse.org [
mailto:tycho-user-***@eclipse.org] On Behalf Of Sievers, Jan
Sent: Thursday, April 17, 2014 2:04 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by
default.

You can configure tycho-compiler-plugin to use a custom JDT compiler
version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308


Best Regards,
Jan

From: tycho-user-***@eclipse.org [
mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't
seem to have the latest compiler in it. Or am I wrong on that? I'm writing
a tutorial on JavaFX in Java 8 and would like to show a magic free way of
building.

Thanks,
Doug



From: tycho-user-***@eclipse.org [tycho-user-***@eclipse.org] on
behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want
an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org [
mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug
431793. Is this release planned before the Luna release? We would like to
build our project with a released version of Tycho in time for Luna so it
would be good to know.

Regards,
Marc-Andre

This e-mail, including any attached files, may contain confidential and
privileged information for the sole use of the intended recipient. Any
review, use, distribution, or disclosure by others is strictly prohibited.
If you are not the intended recipient (or authorized to receive
information for the intended recipient), please contact the sender by
reply e-mail and delete all copies of this message.
_______________________________________________
tycho-user mailing list
tycho-***@eclipse.org
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
tycho-***@eclipse.org
https://dev.eclipse.org/mailman/listinfo/tycho-user
Justin Georgeson
2014-04-18 14:30:10 UTC
Permalink
I’m just looking for the compiler. Our product doesn’t ship the JDT

Setting up a toolchain for my 1.8.0 JDK didn’t help with the NPE. It’s actually turning out to be unrelated to Java 8 and JDT so I’ll start a new thread.

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of David M Williams
Sent: Thursday, April 17, 2014 5:37 PM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

> Thanks. Wasn’t sure if you could mix the 3.10 JDT with an otherwise
> Kepler platform but will move forward with it.

To be sure we are talking about the same thing ... my reply was meant as "what to use as the compiler" ... if you are looking at something to _ distribute _ then you are right, you shouldn't mix, and you can use the version in the patch itself, which you can get from repo at .../eclipse/updates/4.3-P-builds/

> With Tycho 0.20.0, JDK 1.8.0, and JDT 3.10 I’m getting an NPE from
> maven trying to resolve project dependencies of an eclipse-plugin
> project for a platform fragment bundle, but not all of the platform
> fragment bundle projects so it’s probably something on my end in
> that one project.

To cover the basics ... if you are re-compiling platform projects, I'm assuming you know that you'll need to define a "toolchains.xml" file and "useJDK" ... as mostly described in
https://wiki.eclipse.org/Platform-releng/Platform_Build#Using_BREE_Libs

HTH




From: Justin Georgeson <***@lgc.com<mailto:***@lgc.com>>
To: Tycho user list <tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>>,
Date: 04/17/2014 05:04 PM
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
Sent by: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org>
________________________________



Thanks. Wasn’t sure if you could mix the 3.10 JDT with an otherwise Kepler platform but will move forward with it.

With Tycho 0.20.0, JDK 1.8.0, and JDT 3.10 I’m getting an NPE from maven trying to resolve project dependencies of an eclipse-plugin project for a platform fragment bundle, but not all of the platform fragment bundle projects so it’s probably something on my end in that one project.

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of David M Williams
Sent: Thursday, April 17, 2014 1:08 PM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

3.10.0.v20140316-0146 is equivalent and was explicitly decided not to put "patch version" in eclipse-staging (bug 430549<https://bugs.eclipse.org/bugs/show_bug.cgi?id=430549>) since we assumed it'd be "out of date" soon, with no maintenance planed, as improvements and fixes made would be on main (Luna) stream. In fact, for almost any purpose, I'd recommend the latest (as indicated in Jan's link):

<cbi-jdt-repo.url>https://repo.eclipse.org/content/repositories/eclipse-staging/</cbi-jdt-repo.url>
<cbi-jdt-version>3.10.0.v20140408-1345</cbi-jdt-version>

[And, keep in mind, neither of these are "released" in normal sense of the word, and will be going away, some day.]






From: Justin Georgeson <***@lgc.com<mailto:***@lgc.com>>
To: Tycho user list <tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>>,
Date: 04/17/2014 01:09 PM
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
Sent by: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org>
________________________________




Is there a pluginRepository where we can get the Kepler feature patch version of JDT (3.9.50.v20140371-1741)?

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Sievers, Jan
Sent: Thursday, April 17, 2014 2:04 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

both tycho 0.20.0 and 0.21.0-SNAPSHOT still use the Kepler JDT compiler by default.

You can configure tycho-compiler-plugin to use a custom JDT compiler version though, see e.g. eclipse platform build:

http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/tree/eclipse-platform-parent/pom.xml#n308

Best Regards,
Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________


From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
________________________________

This e-mail, including any attached files, may contain confidential and privileged information for the sole use of the intended recipient. Any review, use, distribution, or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive information for the intended recipient), please contact the sender by reply e-mail and delete all copies of this message._______________________________________________
tycho-user mailing list
tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
https://dev.eclipse.org/mailman/listinfo/tycho-user_______________________________________________
tycho-user mailing list
tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
https://dev.eclipse.org/mailman/listinfo/tycho-user
Oberlies, Tobias
2014-04-19 09:50:11 UTC
Permalink
FYI - the bug to include a the new JDT compiler is here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=430986 The bug status is up to date (as with most of our bugs), so this is not yet done.

Regards
Tobias

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Doug Schaefer
Sent: Mittwoch, 16. April 2014 16:25
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?

Speaking of Java 8, I tried the snapshot yesterday and it still doesn't seem to have the latest compiler in it. Or am I wrong on that? I'm writing a tutorial on JavaFX in Java 8 and would like to show a magic free way of building.

Thanks,
Doug

________________________________
From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [tycho-user-***@eclipse.org] on behalf of Sievers, Jan [***@sap.com]
Sent: Wednesday, April 16, 2014 3:25 AM
To: Tycho user list
Subject: Re: [tycho-user] Estimated release date of 0.21.0?
no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Marc-André Laperle
Sent: Dienstag, 15. April 2014 16:34
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: [tycho-user] Estimated release date of 0.21.0?

Hello,

We would like to use Tycho version 0.21.0 because we are affected by bug 431793<https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793>. Is this release planned before the Luna release? We would like to build our project with a released version of Tycho in time for Luna so it would be good to know.

Regards,
Marc-Andre
Marc-André Laperle
2014-04-21 05:42:47 UTC
Permalink
Hello Jan,

Thank you for your reply. Unfortunately, it seems adding environment variables like mentioned in the workaround can easily lead to portability problems. For example:

<environmentVariables>
<DISPLAY>${env.DISPLAY}</DISPLAY>
</environmentVariables>

If I run this on Windows, I get a NPE (see below). Most likely because ${env.DISPLAY} is not defined. To work around this problem, I could define profiles but I've also seen inconsistencies between the environment variables that need to be "passed" when using different Linux distributions so as I add more of them, the NPE is more likely to manifest itself. It sounds like it might just be easier to go back to 0.19.0 for now and upgrade to 0.21.0 when it's officially released.

Thank you,
Marc-Andre

[ERROR] Failed to execute goal org.eclipse.tycho:tycho-surefire-plugin:0.20.0:test (default-test) on project org.eclipse.linuxtools.tmf.ui.swtbot.test
s: Error while executing platform: NullPointerException -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.eclipse.tycho:tycho-surefire-plugin:0.20.0:test (default-test) on project org.eclipse.linuxtools.tmf.ui.swtbot.tests: Error while executing platform
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.apache.maven.plugin.MojoExecutionException: Error while executing platform
at org.eclipse.tycho.surefire.TestMojo.runTest(TestMojo.java:945)
at org.eclipse.tycho.surefire.TestMojo.execute(TestMojo.java:668)
at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
... 19 more
Caused by: java.lang.NullPointerException
at org.apache.commons.exec.environment.EnvironmentUtils.toStrings(EnvironmentUtils.java:66)
at org.apache.commons.exec.launcher.Java13CommandLauncher.exec(Java13CommandLauncher.java:56)
at org.apache.commons.exec.DefaultExecutor.launch(DefaultExecutor.java:277)
at org.apache.commons.exec.DefaultExecutor.executeInternal(DefaultExecutor.java:334)
at org.apache.commons.exec.DefaultExecutor.execute(DefaultExecutor.java:164)
at org.eclipse.sisu.equinox.launching.internal.DefaultEquinoxLauncher.execute(DefaultEquinoxLauncher.java:71)
at org.eclipse.tycho.surefire.TestMojo.runTest(TestMojo.java:943)
... 22 more

no ETA for 0.21.0 yet. Probably shortly after Luna I guess since we want an officially released and stable Java-8 capable JDT compiler.

Regarding bug 431793, a workaround is mentioned in the bug.
Can you live with a workaround until 0.21.0 is released?

Jan
Continue reading on narkive:
Loading...