Discussion:
How do I Merge p2 repository builds
(too old to reply)
Nadav Hoze
2012-07-25 06:10:42 UTC
Permalink
Hi,

I created an update-site for set of plugins with a feature.
All is built by tycho and the site is on http server and everything works
as it should.
BUT how do I merge new build with previous build for backward compatability?

I tried to use the
org.eclipse.tycho.extras:tycho-p2-extras-plugin:0.14.0:mirror goal but I
get the following error.

*Unable to parse configuration of mojo
org.eclipse.tycho.extras:tycho-p2-extras-plugin:0.14.0:mirror for parameter
destination: Cannot configure instance of
org.eclipse.tycho.plugins.p2.extras.Repository from
C:\Sapiens\spml\sources\ide\spml-plugin-update-site\target/repository*

please help, this is my pom file (just copied it from
http://wiki.eclipse.org/Tycho/Additional_Tools):

<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it
from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>

<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->

<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->


<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>


Thanks,

Nadav
Simon Goodall
2012-07-25 06:42:11 UTC
Permalink
Hi,

Which version of Tycho are you using? You might want to try using the
same version of Tycho and Tycho-Extras.

I would also suggest checking the execution order is as expected - I
suspect things are not happening in the order you expect.

Simon
Post by Nadav Hoze
Hi,
I created an update-site for set of plugins with a feature.
All is built by tycho and the site is on http server and everything works as
it should.
BUT how do I merge new build with previous build for backward compatability?
I tried to use the
org.eclipse.tycho.extras:tycho-p2-extras-plugin:0.14.0:mirror goal but I get
the following error.
Unable to parse configuration of mojo
org.eclipse.tycho.extras:tycho-p2-extras-plugin:0.14.0:mirror for parameter
destination: Cannot configure instance of
org.eclipse.tycho.plugins.p2.extras.Repository from
C:\Sapiens\spml\sources\ide\spml-plugin-update-site\target/repository
please help, this is my pom file (just copied it from
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it
from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
Thanks,
Nadav
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Nadav Hoze
2012-07-25 07:00:08 UTC
Permalink
Hi,

I'm using tycho version 0.14.1

but in Tycho-Extras there is no version 0.14.1, so I used version 0.14.0.

regarding the order I did change the the phase mirror goal
from prepare-package to package because the packaging of the repository was
not created and I though that this is the problem.

please tell me how should I set the configuration right ?

here is my entire pom, if you need anything else let me know.

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<artifactId>spml-plugin-update-site</artifactId>
<packaging>eclipse-repository</packaging>
<name>Spml Update Site</name>

<parent>
<artifactId>spml-tycho-parent</artifactId>
<groupId>com.sapiens.spml</groupId>
<version>${spml.bundle.version}</version>
<relativePath>../spml-tycho-parent</relativePath>
</parent>


<dependencies>
<dependency>
<artifactId>com.sapiens.spml.tool.ide</artifactId>
<groupId>com.sapiens.spml</groupId>
<scope>provided</scope>
</dependency>
</dependencies>

<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it from confidentiality reasons -->

<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>

<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->

<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->


<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
</project>

Thanks,

Nadav
Post by Simon Goodall
Hi,
Which version of Tycho are you using? You might want to try using the
same version of Tycho and Tycho-Extras.
I would also suggest checking the execution order is as expected - I
suspect things are not happening in the order you expect.
Simon
Post by Nadav Hoze
Hi,
I created an update-site for set of plugins with a feature.
All is built by tycho and the site is on http server and everything
works as
Post by Nadav Hoze
it should.
BUT how do I merge new build with previous build for backward
compatability?
Post by Nadav Hoze
I tried to use the
org.eclipse.tycho.extras:tycho-p2-extras-plugin:0.14.0:mirror goal but I
get
Post by Nadav Hoze
the following error.
Unable to parse configuration of mojo
org.eclipse.tycho.extras:tycho-p2-extras-plugin:0.14.0:mirror for
parameter
Post by Nadav Hoze
destination: Cannot configure instance of
org.eclipse.tycho.plugins.p2.extras.Repository from
C:\Sapiens\spml\sources\ide\spml-plugin-update-site\target/repository
please help, this is my pom file (just copied it from
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed
it
Post by Nadav Hoze
from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
Thanks,
Nadav
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Simon Goodall
2012-07-25 08:09:36 UTC
Permalink
I can't see anything obvious. Can you reproduce it in a stand alone case?
Have you tried Tycho 0.15.0? Also try running mvn with -X to see full
debugging output.

Simon
Post by Nadav Hoze
Hi,
I'm using tycho version 0.14.1
but in Tycho-Extras there is no version 0.14.1, so I used version 0.14.0.
regarding the order I did change the the phase mirror goal from
prepare-package to package because the packaging of the repository was not
created and I though that this is the problem.
please tell me how should I set the configuration right ?
here is my entire pom, if you need anything else let me know.
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<artifactId>spml-plugin-update-site</artifactId>
<packaging>eclipse-repository</packaging>
<name>Spml Update Site</name>
<parent>
<artifactId>spml-tycho-parent</artifactId>
<groupId>com.sapiens.spml</groupId>
<version>${spml.bundle.version}</version>
<relativePath>../spml-tycho-parent</relativePath>
</parent>
<dependencies>
<dependency>
<artifactId>com.sapiens.spml.tool.ide</artifactId>
<groupId>com.sapiens.spml</groupId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
</project>
Thanks,
Nadav
Nadav Hoze
2012-07-25 08:31:11 UTC
Permalink
silly me :-) the xml structure was wrong the configuration details were
inside <source> element when it should be inside the <configuration>
element.
see :

<source>
<!-- source repositories to mirror from -->
<repository>
<url>file:///C:/Sapiens/spml/branches/ide_release_v1_1/spml-plugin-update-site/target/repository</url>
<layout>p2-metadata</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->

<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>com.sapiens.spml.tool.ide</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>

<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->


<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>true</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>

This happened because I copied it from the wiki (
http://wiki.eclipse.org/Tycho/Additional_Tools )
and there the closing </source> was written &lt;/source>.
So now it mirrors, I'm testing it, if I'll encounter anything else I'll let
you know thanks for the help,

Nadav
Post by Simon Goodall
I can't see anything obvious. Can you reproduce it in a stand alone case?
Have you tried Tycho 0.15.0? Also try running mvn with -X to see full
debugging output.
Simon
Post by Nadav Hoze
Hi,
I'm using tycho version 0.14.1
but in Tycho-Extras there is no version 0.14.1, so I used version
0.14.0.
Post by Nadav Hoze
regarding the order I did change the the phase mirror goal from
prepare-package to package because the packaging of the repository was
not
Post by Nadav Hoze
created and I though that this is the problem.
please tell me how should I set the configuration right ?
here is my entire pom, if you need anything else let me know.
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<artifactId>spml-plugin-update-site</artifactId>
<packaging>eclipse-repository</packaging>
<name>Spml Update Site</name>
<parent>
<artifactId>spml-tycho-parent</artifactId>
<groupId>com.sapiens.spml</groupId>
<version>${spml.bundle.version}</version>
<relativePath>../spml-tycho-parent</relativePath>
</parent>
<dependencies>
<dependency>
<artifactId>com.sapiens.spml.tool.ide</artifactId>
<groupId>com.sapiens.spml</groupId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
</project>
Thanks,
Nadav
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Jeff MAURY
2012-07-25 09:13:11 UTC
Permalink
I am trying to use this plugin but I am facing an error on Windows.
I try to mirror the repo that is being generated by Tycho from my product
file.
So I use the notation ${project.build.directory}/repository as the url for
the source repository.
As it is defined as an URI, the conversion fails because of the \
characters
Do you know how to fix the problem ? Or do I have to use an hard coded
value (like in the example below) ?

Jeff
Post by Nadav Hoze
silly me :-) the xml structure was wrong the configuration details were
inside <source> element when it should be inside the <configuration>
element.
<source>
<!-- source repositories to mirror from -->
<repository>
<url>file:///C:/Sapiens/spml/branches/ide_release_v1_1/spml-plugin-update-site/target/repository</url>
<layout>p2-metadata</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>com.sapiens.spml.tool.ide</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>true</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
This happened because I copied it from the wiki (
http://wiki.eclipse.org/Tycho/Additional_Tools )
and there the closing </source> was written &lt;/source>.
So now it mirrors, I'm testing it, if I'll encounter anything else I'll
let you know thanks for the help,
Nadav
Post by Simon Goodall
I can't see anything obvious. Can you reproduce it in a stand alone case?
Have you tried Tycho 0.15.0? Also try running mvn with -X to see full
debugging output.
Simon
Post by Nadav Hoze
Hi,
I'm using tycho version 0.14.1
but in Tycho-Extras there is no version 0.14.1, so I used version
0.14.0.
Post by Nadav Hoze
regarding the order I did change the the phase mirror goal from
prepare-package to package because the packaging of the repository was
not
Post by Nadav Hoze
created and I though that this is the problem.
please tell me how should I set the configuration right ?
here is my entire pom, if you need anything else let me know.
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<artifactId>spml-plugin-update-site</artifactId>
<packaging>eclipse-repository</packaging>
<name>Spml Update Site</name>
<parent>
<artifactId>spml-tycho-parent</artifactId>
<groupId>com.sapiens.spml</groupId>
<version>${spml.bundle.version}</version>
<relativePath>../spml-tycho-parent</relativePath>
</parent>
<dependencies>
<dependency>
<artifactId>com.sapiens.spml.tool.ide</artifactId>
<groupId>com.sapiens.spml</groupId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
</project>
Thanks,
Nadav
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Jeff MAURY


"Legacy code" often differs from its suggested alternative by actually
working and scaling.
- Bjarne Stroustrup

http://www.jeffmaury.com
http://riadiscuss.jeffmaury.com
http://www.twitter.com/jeffmaury
Nadav Hoze
2012-07-25 10:06:21 UTC
Permalink
so it means that they do not use the url encoder before parsing it.
So I guess that till this will be fixed you have 2 options:
1. move your build directory to a path without spaces,
2. use hard-coded encoded url (which is bad).

But maybe I'm wrong and you need an answer from a tycho developer.

Thanks,

Nadav
Post by Jeff MAURY
I am trying to use this plugin but I am facing an error on Windows.
I try to mirror the repo that is being generated by Tycho from my product
file.
So I use the notation ${project.build.directory}/repository as the url for
the source repository.
As it is defined as an URI, the conversion fails because of the \
characters
Do you know how to fix the problem ? Or do I have to use an hard coded
value (like in the example below) ?
Jeff
Post by Nadav Hoze
silly me :-) the xml structure was wrong the configuration details were
inside <source> element when it should be inside the <configuration>
element.
<source>
<!-- source repositories to mirror from -->
<repository>
<url>file:///C:/Sapiens/spml/branches/ide_release_v1_1/spml-plugin-update-site/target/repository</url>
<layout>p2-metadata</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>com.sapiens.spml.tool.ide</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>true</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
This happened because I copied it from the wiki (
http://wiki.eclipse.org/Tycho/Additional_Tools )
and there the closing </source> was written &lt;/source>.
So now it mirrors, I'm testing it, if I'll encounter anything else I'll
let you know thanks for the help,
Nadav
Post by Simon Goodall
I can't see anything obvious. Can you reproduce it in a stand alone case?
Have you tried Tycho 0.15.0? Also try running mvn with -X to see full
debugging output.
Simon
Post by Nadav Hoze
Hi,
I'm using tycho version 0.14.1
but in Tycho-Extras there is no version 0.14.1, so I used version
0.14.0.
Post by Nadav Hoze
regarding the order I did change the the phase mirror goal from
prepare-package to package because the packaging of the repository was
not
Post by Nadav Hoze
created and I though that this is the problem.
please tell me how should I set the configuration right ?
here is my entire pom, if you need anything else let me know.
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<artifactId>spml-plugin-update-site</artifactId>
<packaging>eclipse-repository</packaging>
<name>Spml Update Site</name>
<parent>
<artifactId>spml-tycho-parent</artifactId>
<groupId>com.sapiens.spml</groupId>
<version>${spml.bundle.version}</version>
<relativePath>../spml-tycho-parent</relativePath>
</parent>
<dependencies>
<dependency>
<artifactId>com.sapiens.spml.tool.ide</artifactId>
<groupId>com.sapiens.spml</groupId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
</project>
Thanks,
Nadav
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Jeff MAURY
"Legacy code" often differs from its suggested alternative by actually
working and scaling.
- Bjarne Stroustrup
http://www.jeffmaury.com
http://riadiscuss.jeffmaury.com
http://www.twitter.com/jeffmaury
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Simon Goodall
2012-07-25 10:08:15 UTC
Permalink
You can use something like ${project.baseUri} to get a URI to your project.
For example;

<url>${project.baseUri}/target/repository</url>

Simon
Post by Jeff MAURY
I am trying to use this plugin but I am facing an error on Windows.
I try to mirror the repo that is being generated by Tycho from my product
file.
So I use the notation ${project.build.directory}/repository as the url for
the source repository.
As it is defined as an URI, the conversion fails because of the \
characters
Do you know how to fix the problem ? Or do I have to use an hard coded
value (like in the example below) ?
Jeff
Post by Nadav Hoze
silly me :-) the xml structure was wrong the configuration details were
inside <source> element when it should be inside the <configuration>
element.
<source>
<!-- source repositories to mirror from -->
<repository>
<url>file:///C:/Sapiens/spml/branches/ide_release_v1_1/spml-plugin-update-site/target/repository</url>
<layout>p2-metadata</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>com.sapiens.spml.tool.ide</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>true</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
This happened because I copied it from the wiki (
http://wiki.eclipse.org/Tycho/Additional_Tools )
and there the closing </source> was written &lt;/source>.
So now it mirrors, I'm testing it, if I'll encounter anything else I'll
let you know thanks for the help,
Nadav
Post by Simon Goodall
I can't see anything obvious. Can you reproduce it in a stand alone case?
Have you tried Tycho 0.15.0? Also try running mvn with -X to see full
debugging output.
Simon
Post by Nadav Hoze
Hi,
I'm using tycho version 0.14.1
but in Tycho-Extras there is no version 0.14.1, so I used version
0.14.0.
Post by Nadav Hoze
regarding the order I did change the the phase mirror goal from
prepare-package to package because the packaging of the repository was
not
Post by Nadav Hoze
created and I though that this is the problem.
please tell me how should I set the configuration right ?
here is my entire pom, if you need anything else let me know.
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<artifactId>spml-plugin-update-site</artifactId>
<packaging>eclipse-repository</packaging>
<name>Spml Update Site</name>
<parent>
<artifactId>spml-tycho-parent</artifactId>
<groupId>com.sapiens.spml</groupId>
<version>${spml.bundle.version}</version>
<relativePath>../spml-tycho-parent</relativePath>
</parent>
<dependencies>
<dependency>
<artifactId>com.sapiens.spml.tool.ide</artifactId>
<groupId>com.sapiens.spml</groupId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
</project>
Thanks,
Nadav
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Jeff MAURY
"Legacy code" often differs from its suggested alternative by actually
working and scaling.
- Bjarne Stroustrup
http://www.jeffmaury.com
http://riadiscuss.jeffmaury.com
http://www.twitter.com/jeffmaury
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
Jeff MAURY
2012-07-25 11:26:36 UTC
Permalink
Works lile a charm
Thanks for the tip

Jeff
Post by Simon Goodall
You can use something like ${project.baseUri} to get a URI to your
project. For example;
<url>${project.baseUri}/target/repository</url>
Simon
Post by Jeff MAURY
I am trying to use this plugin but I am facing an error on Windows.
I try to mirror the repo that is being generated by Tycho from my product
file.
So I use the notation ${project.build.directory}/repository as the url
for the source repository.
As it is defined as an URI, the conversion fails because of the \
characters
Do you know how to fix the problem ? Or do I have to use an hard coded
value (like in the example below) ?
Jeff
Post by Nadav Hoze
silly me :-) the xml structure was wrong the configuration details were
inside <source> element when it should be inside the <configuration>
element.
<source>
<!-- source repositories to mirror from -->
<repository>
<url>file:///C:/Sapiens/spml/branches/ide_release_v1_1/spml-plugin-update-site/target/repository</url>
<layout>p2-metadata</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>com.sapiens.spml.tool.ide</id> </iu> </ius> -->
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>true</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
This happened because I copied it from the wiki (
http://wiki.eclipse.org/Tycho/Additional_Tools )
and there the closing </source> was written &lt;/source>.
So now it mirrors, I'm testing it, if I'll encounter anything else I'll
let you know thanks for the help,
Nadav
On Wed, Jul 25, 2012 at 11:09 AM, Simon Goodall <
Post by Simon Goodall
I can't see anything obvious. Can you reproduce it in a stand alone case?
Have you tried Tycho 0.15.0? Also try running mvn with -X to see full
debugging output.
Simon
Post by Nadav Hoze
Hi,
I'm using tycho version 0.14.1
but in Tycho-Extras there is no version 0.14.1, so I used version
0.14.0.
Post by Nadav Hoze
regarding the order I did change the the phase mirror goal from
prepare-package to package because the packaging of the repository
was not
Post by Nadav Hoze
created and I though that this is the problem.
please tell me how should I set the configuration right ?
here is my entire pom, if you need anything else let me know.
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<artifactId>spml-plugin-update-site</artifactId>
<packaging>eclipse-repository</packaging>
<name>Spml Update Site</name>
<parent>
<artifactId>spml-tycho-parent</artifactId>
<groupId>com.sapiens.spml</groupId>
<version>${spml.bundle.version}</version>
<relativePath>../spml-tycho-parent</relativePath>
</parent>
<dependencies>
<dependency>
<artifactId>com.sapiens.spml.tool.ide</artifactId>
<groupId>com.sapiens.spml</groupId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-p2-extras-plugin</artifactId>
<version>0.14.0</version>
<executions>
<execution>
<phase>package</phase>
<goals>
<goal>mirror</goal>
</goals>
</execution>
</executions>
<configuration>
<source>
<!-- source repositories to mirror from -->
<repository>
<!-- I removed it from confidentiality reasons -->
<url>my-update-site-url</url>
<layout>p2</layout>
<!-- supported layouts are "p2-metadata", "p2-artifacts", and "p2"
(for joint repositories; default) -->
</repository>
<!-- starting from here all configuration parameters are optional -->
<!-- they are only shown here with default values for documentation
purpose -->
<!-- List of IUs to mirror. If omitted, allIUs will be mirrored. -->
<!-- Omitted IU version element means latest version of the IU -->
<!-- <ius> <iu> <id>org.eclipse.rcp.feature.group</id> </iu> </ius>
-->
Post by Nadav Hoze
<!-- The destination directory to mirror to. -->
<destination>${project.build.directory}/repository</destination>
<!-- Whether only strict dependencies should be followed. -->
<!-- "strict" means perfect version match -->
<followStrictOnly>false</followStrictOnly>
<!-- Whether or not to follow optional requirements. -->
<includeOptional>true</includeOptional>
<!-- Whether or not to follow non-greedy requirements. -->
<includeNonGreedy>true</includeNonGreedy>
<!-- Filter properties. E.g. filter only one platform -->
<!-- Whether to filter the resulting set of IUs to only -->
<!-- include the latest version of each IU -->
<latestVersionOnly>false</latestVersionOnly>
<!-- don't mirror artifacts, only metadata -->
<mirrorMetadataOnly>false</mirrorMetadataOnly>
<!-- whether to compress the content.xml/artifacts.xml -->
<compress>true</compress>
<!-- whether to append to the target repository content -->
<append>true</append>
</source>
</configuration>
</plugin>
</plugins>
</build>
</project>
Thanks,
Nadav
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Jeff MAURY
"Legacy code" often differs from its suggested alternative by actually
working and scaling.
- Bjarne Stroustrup
http://www.jeffmaury.com
http://riadiscuss.jeffmaury.com
http://www.twitter.com/jeffmaury
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
_______________________________________________
tycho-user mailing list
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Jeff MAURY


"Legacy code" often differs from its suggested alternative by actually
working and scaling.
- Bjarne Stroustrup

http://www.jeffmaury.com
http://riadiscuss.jeffmaury.com
http://www.twitter.com/jeffmaury
Continue reading on narkive:
Loading...