Discussion:
[Maven & Eclipse]
(too old to reply)
Christelle BURGUERA
2016-01-06 12:14:54 UTC
Permalink
Hello,

I've already maven projects :

- One that builds an UpdateSite with my plugins

- One that builds a Eclipse product (with my branding)
I would like to install the UpdateSite in the product.
I can do it only after because the plugins are built under Kepler and the product under Luna (with Maven it's easy to have 2 differentes versions of Eclipse :))

I think it'll be possible to use the p2 functionality ?
But how ?

Or if you have another idea ?

I'll be able to execute a script if I don't find another idea ... but I'm convinced that it exists ...

Many thanks
Christelle
Timo Lange
2016-01-06 13:52:22 UTC
Permalink
Hello Christelle,

this should be possible with p2.inf instructions.
I don't have experience by myself with this. But perhaps i can support
you by providing some links.

What i have in mind:
- Create a maven project with p2-installable-unit as packaging type [1]
- Create a p2iu.xml file [2]
- Add the proper instructions[3]


https://wiki.eclipse.org/Tycho/Packaging_Types#p2-installable-unit [1]
https://wiki.eclipse.org/Tycho/p2iu.xml [2]
https://wiki.eclipse.org/Equinox/p2/Customizing_Metadata [3]

Maybe anyone else can confirm this. Feedback is appreciated.

Regards,
Timo
Post by Christelle BURGUERA
Hello,
-One that builds an UpdateSite with my plugins
-One that builds a Eclipse product (with my branding)
I would like to install the UpdateSite in the product.
I can do it only after because the plugins are built under Kepler and
the product under Luna (with Maven it’s easy to have 2 differentes
versions of Eclipse J)
I think it’ll be possible to use the p2 functionality ?
But how ?
Or if you have another idea ?
I’ll be able to execute a script if I don’t find another idea … but
I’m convinced that it exists …
Many thanks
Christelle
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Timo Lange
Software-Engineer
Research & Software Development

Flensburger Schiffbau-Gesellschaft mbH & Co. KG
Batteriestraße 52
D-24939 Flensburg

Tel. : +49 461 4940-579
Fax : +49 461 4940-217
Mail : ***@fsg-ship.de
Web : http://www.fsg-ship.de



============================================================================
FLENSBURGER SCHIFFBAU-GESELLSCHAFT mbH & Co. KG
Batteriestrasse 52, 24939 Flensburg

Sitz der Gesellschaft / Place of business : Flensburg
Managing Director / CEO : Ulf Bertheau
Handelregister / Commercial register : Amtsgericht Flensburg, HRA 3140
Steuer Nr. / Tax number: 1528040009
USt.-Id-Nr. / VAT no : DE 134633705
Amtsgericht / District court : Flensburg HRB 2036
============================================================================


============================================================================
FLENSBURGER SCHIFFBAU-GESELLSCHAFT mbH & Co. KG
Batteriestrasse 52, 24939 Flensburg

Sitz der Gesellschaft / Place of business : Flensburg
Geschaeftsfuehrer / Managing Director : Ulf Bertheau
Handelregister / Commercial register : Amtsgericht Flensburg, HRA 3140
Steuer Nr. / Tax number: 1528040009
USt.-Id-Nr. / VAT no : DE 134633705
Amtsgericht / District court : Flensburg HRB 2036
============================================================================

The information contained in this email message may be privileged and
confidential. If you have received this communication in error, please
notify the sender immediately by telephoning (+49-461-49400) and return this
message to the above address. Thank you.
Mickael Istria
2016-01-06 14:05:28 UTC
Permalink
Post by Christelle BURGUERA
Hello,
Hi Christelle,
Post by Christelle BURGUERA
-One that builds an UpdateSite with my plugins
-One that builds a Eclipse product (with my branding)
I would like to install the UpdateSite in the product.
I can do it only after because the plugins are built under Kepler and
the product under Luna (with Maven it’s easy to have 2 differentes
versions of Eclipse J)
I think it’ll be possible to use the p2 functionality ?
But how ?
Or if you have another idea ?
If you want to add p2 repository to your product, you'll have to tweak a
p2.inf:
https://wiki.eclipse.org/Equinox/p2/Adding_Self-Update_to_an_RCP_Application#Configuring_the_user.27s_default_repositories
If by install you mean "install contents", then from Tycho or p2
perspective, the "update-site" isn't something you can install nor
depend on. It's more a packaging than an artifact. Maybe if you want to
better factorize content of p2 repo and content of your product, you'd
rather rely on a feature that would be in both your p2 repo and your
product.

HTH,
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat <http://www.jboss.org/tools>
My blog <http://mickaelistria.wordpress.com> - My Tweets
<http://twitter.com/mickaelistria>
Timo Lange
2016-01-06 14:11:58 UTC
Permalink
Post by Mickael Istria
Post by Christelle BURGUERA
Hello,
Hi Christelle,
Post by Christelle BURGUERA
-One that builds an UpdateSite with my plugins
-One that builds a Eclipse product (with my branding)
I would like to install the UpdateSite in the product.
I can do it only after because the plugins are built under Kepler and
the product under Luna (with Maven it’s easy to have 2 differentes
versions of Eclipse J)
I think it’ll be possible to use the p2 functionality ?
But how ?
Or if you have another idea ?
If you want to add p2 repository to your product, you'll have to tweak
https://wiki.eclipse.org/Equinox/p2/Adding_Self-Update_to_an_RCP_Application#Configuring_the_user.27s_default_repositories
If by install you mean "install contents", then from Tycho or p2
perspective, the "update-site" isn't something you can install nor
depend on. It's more a packaging than an artifact. Maybe if you want
to better factorize content of p2 repo and content of your product,
you'd rather rely on a feature that would be in both your p2 repo and
your product.
HTH,
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat <http://www.jboss.org/tools>
My blog <http://mickaelistria.wordpress.com> - My Tweets
<http://twitter.com/mickaelistria>
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Timo Lange
Software-Engineer
Research & Software Development

Flensburger Schiffbau-Gesellschaft mbH & Co. KG
Batteriestraße 52
D-24939 Flensburg

Tel. : +49 461 4940-579
Fax : +49 461 4940-217
Mail : ***@fsg-ship.de
Web : http://www.fsg-ship.de



============================================================================
FLENSBURGER SCHIFFBAU-GESELLSCHAFT mbH & Co. KG
Batteriestrasse 52, 24939 Flensburg

Sitz der Gesellschaft / Place of business : Flensburg
Managing Director / CEO : Ulf Bertheau
Handelregister / Commercial register : Amtsgericht Flensburg, HRA 3140
Steuer Nr. / Tax number: 1528040009
USt.-Id-Nr. / VAT no : DE 134633705
Amtsgericht / District court : Flensburg HRB 2036
============================================================================


============================================================================
FLENSBURGER SCHIFFBAU-GESELLSCHAFT mbH & Co. KG
Batteriestrasse 52, 24939 Flensburg

Sitz der Gesellschaft / Place of business : Flensburg
Geschaeftsfuehrer / Managing Director : Ulf Bertheau
Handelregister / Commercial register : Amtsgericht Flensburg, HRA 3140
Steuer Nr. / Tax number: 1528040009
USt.-Id-Nr. / VAT no : DE 134633705
Amtsgericht / District court : Flensburg HRB 2036
============================================================================

The information contained in this email message may be privileged and
confidential. If you have received this communication in error, please
notify the sender immediately by telephoning (+49-461-49400) and return this
message to the above address. Thank you.
Timo Lange
2016-01-06 14:26:19 UTC
Permalink
Mickael,

so it's not possible to install a feature from a p2 repo using the
p2.inf file?
In your former case you just add the p2-repository URLs to the product.
That's easy.
But how about the latter case?

Image a case where the features are ONLY available through an p2-repo.
I don't get the sources nor the binary features. Only a URL to the p2 repo.

I could use the p2-director application.
But then i have to write a script which will be invoked after the tycho
build.
And like Christelle already said, you can do this but it's rude.

What are the p2 inf install instructions then made for?

Regards,
Timo
Post by Mickael Istria
Post by Christelle BURGUERA
Hello,
Hi Christelle,
Post by Christelle BURGUERA
-One that builds an UpdateSite with my plugins
-One that builds a Eclipse product (with my branding)
I would like to install the UpdateSite in the product.
I can do it only after because the plugins are built under Kepler and
the product under Luna (with Maven it’s easy to have 2 differentes
versions of Eclipse J)
I think it’ll be possible to use the p2 functionality ?
But how ?
Or if you have another idea ?
If you want to add p2 repository to your product, you'll have to tweak
https://wiki.eclipse.org/Equinox/p2/Adding_Self-Update_to_an_RCP_Application#Configuring_the_user.27s_default_repositories
If by install you mean "install contents", then from Tycho or p2
perspective, the "update-site" isn't something you can install nor
depend on. It's more a packaging than an artifact. Maybe if you want
to better factorize content of p2 repo and content of your product,
you'd rather rely on a feature that would be in both your p2 repo and
your product.
HTH,
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat <http://www.jboss.org/tools>
My blog <http://mickaelistria.wordpress.com> - My Tweets
<http://twitter.com/mickaelistria>
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Timo Lange
Software-Engineer
Research & Software Development

Flensburger Schiffbau-Gesellschaft mbH & Co. KG
Batteriestraße 52
D-24939 Flensburg

Tel. : +49 461 4940-579
Fax : +49 461 4940-217
Mail : ***@fsg-ship.de
Web : http://www.fsg-ship.de



============================================================================
FLENSBURGER SCHIFFBAU-GESELLSCHAFT mbH & Co. KG
Batteriestrasse 52, 24939 Flensburg

Sitz der Gesellschaft / Place of business : Flensburg
Managing Director / CEO : Ulf Bertheau
Handelregister / Commercial register : Amtsgericht Flensburg, HRA 3140
Steuer Nr. / Tax number: 1528040009
USt.-Id-Nr. / VAT no : DE 134633705
Amtsgericht / District court : Flensburg HRB 2036
============================================================================


============================================================================
FLENSBURGER SCHIFFBAU-GESELLSCHAFT mbH & Co. KG
Batteriestrasse 52, 24939 Flensburg

Sitz der Gesellschaft / Place of business : Flensburg
Geschaeftsfuehrer / Managing Director : Ulf Bertheau
Handelregister / Commercial register : Amtsgericht Flensburg, HRA 3140
Steuer Nr. / Tax number: 1528040009
USt.-Id-Nr. / VAT no : DE 134633705
Amtsgericht / District court : Flensburg HRB 2036
============================================================================

The information contained in this email message may be privileged and
confidential. If you have received this communication in error, please
notify the sender immediately by telephoning (+49-461-49400) and return this
message to the above address. Thank you.
Mickael Istria
2016-01-06 14:45:53 UTC
Permalink
Post by Timo Lange
Image a case where the features are ONLY available through an p2-repo.
I don't get the sources nor the binary features. Only a URL to the p2 repo.
Then you can put a reference to the p2 repo is part of your
target-platform (in a referenced .target or a <repository> in pom.xml),
and you can include them in your product by listing them inside the
.product, just as you add dependency to external bundles in your
MANIFEST.MF.
Post by Timo Lange
What are the p2 inf install instructions then made for?
See https://wiki.eclipse.org/Equinox/p2/Customizing_Metadata
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat <http://www.jboss.org/tools>
My blog <http://mickaelistria.wordpress.com> - My Tweets
<http://twitter.com/mickaelistria>
Christelle BURGUERA
2016-01-08 09:03:23 UTC
Permalink
Thank you for all your answers !
I'll come back to this subject as soon as I resolve another issue.

Because I've some issues with the branding (exported icons, about dialog...) I restart the dev of my product. And it works well :D !
Now I want to generate the same think with maven.

Without speaking about plugins (those I want to add with P2), I want just generate the product.
I've a plugin with the .product file, the plugin is based on a feature (product definition).

So, I've added 2 pom.xml

- 1 for the product
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>pouet.workbench</groupId>
<artifactId>Maven_EclipseProduct</artifactId>
<version>1.6.0-SNAPSHOT</version>
<relativePath>../Maven_EclipseProduct</relativePath>
</parent>

<artifactId>pouet.product</artifactId>
<packaging>eclipse-repository</packaging>
<repositories>
<repository>
<id>eclipse-luna</id>
<layout>p2</layout>
<url>http://download.eclipse.org/releases/luna</url>
</repository>
</repositories>
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-repository-plugin</artifactId>
<version>0.19.0</version>
<configuration>
<includeAllDependencies>true</includeAllDependencies>
</configuration>
</plugin>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>0.19.0</version>
<executions>
<execution>
<id>materialize-products</id>
<goals>
<goal>materialize-products</goal>
</goals>
</execution>
<execution>
<id>archive-products</id>
<goals>
<goal>archive-products</goal>
</goals>
</execution>
</executions>
</plugin>
</plugins>
</build>

</project>

- 1 for the feature
<?xml version="1.0" encoding="UTF-8"?>
<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<modelVersion>4.0.0</modelVersion>
<artifactId>pouet.product.feature</artifactId>
<packaging>eclipse-feature</packaging>
<parent>
<groupId> pouet.workbench</groupId>
<artifactId>Maven_EclipseProduct</artifactId>
<version>1.6.0-SNAPSHOT</version>
<relativePath>../Maven_EclipseProduct</relativePath>
</parent>
</project>


And a Maven parent project with this pom.xml:
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>pouet.workbench</groupId>
<artifactId>Maven_EclipseProduct</artifactId>
<version>1.6.0-SNAPSHOT</version>
<packaging>pom</packaging>
<modules>
<module>../pouet.product</module>
<module>../pouet.feature</module>
</modules>
</project>

And I don't understand why I've this errors:
[ERROR] The project pouet.workbench:pouet.product:1.6.0-SNAPSHOT (C:\pouet.product\pom.xml) has 1 error
[ERROR] Unknown packaging: eclipse-repository @ line 13, column 13
[ERROR]
[ERROR] The project pouet.workbench:pouet.product.feature:1.6.0-SNAPSHOT (C:\pouet.product.feature\pom.xml) has 1 error
[ERROR] Unknown packaging: eclipse-feature @ line 6, column 14

If you have any idea .... I'm looking for this issue for a long time ... I've tried to restart from scratch ... I've searched ... nothing :(
FYI, I'm based on this tuto : http://www.vogella.com/tutorials/EclipseTycho/article.html#exercisetychoproduct

Thank you for your help !
I'll come back with the p2 issue later :)

Chris
Mickael Istria
2016-01-08 09:08:29 UTC
Permalink
Post by Christelle BURGUERA
[ERROR] The project pouet.workbench:pouet.product:1.6.0-SNAPSHOT
(C:\pouet.product\pom.xml) has 1 error
[ERROR]
[ERROR] The project
pouet.workbench:pouet.product.feature:1.6.0-SNAPSHOT
(C:\pouet.product.feature\pom.xml) has 1 error
It seems to me that at that time, the pom.xml of your pouet.product
misses the declaration of tycho extension:
https://wiki.eclipse.org/Tycho/Packaging_Types
Maybe it's just that your poms don't reference the right parent where
the extension is defined?
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat <http://www.jboss.org/tools>
My blog <http://mickaelistria.wordpress.com> - My Tweets
<http://twitter.com/mickaelistria>
Christelle BURGUERA
2016-01-08 09:19:35 UTC
Permalink
I progress, I've add the declaration of tycho extension. I've now dependency issue ...
I don't' understand why I have to add the declaration of tycho extension whereas I've it in the parent pom.

My plugins with the associated features don't have this declaration, only the parent pom has it and it works ...

I try to resolve the dependency issue first ;)

Thank you !

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Mickael Istria
Sent: Friday, January 08, 2016 10:08 AM
To: tycho-***@eclipse.org
Subject: Re: [tycho-user] [Maven & Eclipse]

On 01/08/2016 10:03 AM, Christelle BURGUERA wrote:

And I don't understand why I've this errors:
[ERROR] The project pouet.workbench:pouet.product:1.6.0-SNAPSHOT (C:\pouet.product\pom.xml) has 1 error
[ERROR] Unknown packaging: eclipse-repository @ line 13, column 13
[ERROR]
[ERROR] The project pouet.workbench:pouet.product.feature:1.6.0-SNAPSHOT (C:\pouet.product.feature\pom.xml) has 1 error
[ERROR] Unknown packaging: eclipse-feature @ line 6, column 14


It seems to me that at that time, the pom.xml of your pouet.product misses the declaration of tycho extension: https://wiki.eclipse.org/Tycho/Packaging_Types
Maybe it's just that your poms don't reference the right parent where the extension is defined?
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat<http://www.jboss.org/tools>
My blog<http://mickaelistria.wordpress.com> - My Tweets<http://twitter.com/mickaelistria>
Mickael Istria
2016-01-08 09:23:22 UTC
Permalink
I progress, I’ve add the declaration of tycho extension. I’ve now
dependency issue …
I don’t’ understand why I have to add the declaration of tycho
extension whereas I’ve it in the parent pom.
try "mvn help:effective-pom" to check whether your pom correctly inherit
the content from the right parent.
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat <http://www.jboss.org/tools>
My blog <http://mickaelistria.wordpress.com> - My Tweets
<http://twitter.com/mickaelistria>
Christelle BURGUERA
2016-01-08 13:01:03 UTC
Permalink
Always the dependency issue ... the same with your "mvn help:effective-pom"

I thing the problem I have is :

- pouet.product has a dependency on my pouet.product.feature (without this dependency no launcher icons, no update site... the product doen't have my branding)

- pouet.product.feature has a dependency on my pouet.product (of course because the feature references the plugin which contains the product)

- the parent Pom calls the two modules
<modules>
<module>../fr.ac6.mcu.product</module>
<module>../fr.ac6.mcu.product.feature</module>
</modules>

With the Eclipse Product export wizard mechanism no problem, the product is well generated.

With Maven :
[ERROR] Cannot resolve project dependencies:
[ERROR] Software being installed: pouet.product.feature.feature.group 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product.feature.feature.group 1.6.0.qualifier requires pouet.product 0.0.0' but it could not be found
[ERROR]

It's not a problem of version (pouet.product 0.0.0 => I've tried with 1.6.0 with 1.6.0.qualifier...).
I thing Maven doesn't manager the cross dependency ...

Any idea?
From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Mickael Istria
Sent: Friday, January 08, 2016 10:23 AM
To: tycho-***@eclipse.org
Subject: Re: [tycho-user] [Maven & Eclipse]

On 01/08/2016 10:19 AM, Christelle BURGUERA wrote:
I progress, I've add the declaration of tycho extension. I've now dependency issue ...
I don't' understand why I have to add the declaration of tycho extension whereas I've it in the parent pom.
try "mvn help:effective-pom" to check whether your pom correctly inherit the content from the right parent.
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat<http://www.jboss.org/tools>
My blog<http://mickaelistria.wordpress.com> - My Tweets<http://twitter.com/mickaelistria>
Christelle BURGUERA
2016-01-11 12:27:58 UTC
Permalink
Hello,

I really don't understand what it's wrong ...
I tried to do my product with plugins and not features to put only the product module (<module>../pouet.product</module>) to not have the cross dependency
I need to put the pouet.product in the "Dependencies" under the .product, without the export doesn't contain my branding.
But I have this error with the build maven :

[ERROR] Failed to execute goal org.eclipse.tycho:tycho-p2-publisher-plugin:0.19.0:publish-products (default-publish-products) on project pouet.product: Exception while publishing product C:\pouet.product\pouet.product.product: publishing result: [Included element pouet.product 0.0.0 is missing. Cannot determine filter for requirement to this element.; The features specified in the product definition are ignored; verify the value of the 'type' or 'useFeatures' attribute. ] -> [Help 1]

Is somebody have a Maven example for this architecture for an Eclipse Product:
Maven parent who call
Plugin with product (based on features for the Product Definition)
Feature
???

For information I'm under Luna and I use Tycho 0.19.0.

Many thank !
Christelle
From: Christelle BURGUERA
Sent: Friday, January 08, 2016 2:01 PM
To: tycho-***@eclipse.org
Subject: RE: [tycho-user] [Maven & Eclipse]

Always the dependency issue ... the same with your "mvn help:effective-pom"

I thing the problem I have is :

- pouet.product has a dependency on my pouet.product.feature (without this dependency no launcher icons, no update site... the product doen't have my branding)

- pouet.product.feature has a dependency on my pouet.product (of course because the feature references the plugin which contains the product)

- the parent Pom calls the two modules
<modules>
<module>../pouet.product</module>
<module>../pouet.product.feature</module>
</modules>

With the Eclipse Product export wizard mechanism no problem, the product is well generated.

With Maven :
[ERROR] Cannot resolve project dependencies:
[ERROR] Software being installed: pouet.product.feature.feature.group 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product.feature.feature.group 1.6.0.qualifier requires pouet.product 0.0.0' but it could not be found
[ERROR]

It's not a problem of version (pouet.product 0.0.0 => I've tried with 1.6.0 with 1.6.0.qualifier...).
I thing Maven doesn't manager the cross dependency ...

Any idea?
Nick Boldt
2016-01-11 20:28:19 UTC
Permalink
In Red Hat JBoss Developer Studio, we do this:

a) define the branding plugin
b) define a feature that contains that plugin
c) define a .product which uses the plugin, and includes the feature
d) define an update site which includes & builds the .product

So we have 4 poms, with no circular dependency:

* root pom.xml (simple entry point to build the child modules in
plugins, features, and site via a single reactor)
* plugins/pom.xml
* features/pom.xml
* site/pom.xml (which also builds the .product)

This code is available to peruse here:

https://developers.redhat.com/download-manager/file/jboss-devstudio-9.0.0.GA-source.zip

On Mon, Jan 11, 2016 at 7:27 AM, Christelle BURGUERA
Post by Christelle BURGUERA
Hello,
I really don’t understand what it’s wrong …
I tried to do my product with plugins and not features to put only the
product module (<module>../pouet.product</module>) to not have the cross
dependency
I need to put the pouet.product in the “Dependencies” under the .product,
without the export doesn’t contain my branding.
[ERROR] Failed to execute goal
org.eclipse.tycho:tycho-p2-publisher-plugin:0.19.0:publish-products
(default-publish-products) on project pouet.product: Exception while
publishing product C:\pouet.product\pouet.product.product: publishing
result: [Included element pouet.product 0.0.0 is missing. Cannot determine
filter for requirement to this element.; The features specified in the
product definition are ignored; verify the value of the 'type' or
'useFeatures' attribute. ] -> [Help 1]
Maven parent who call
Plugin with product (based on features for the Product Definition)
Feature
???
For information I’m under Luna and I use Tycho 0.19.0.
Many thank !
Christelle
From: Christelle BURGUERA
Sent: Friday, January 08, 2016 2:01 PM
Subject: RE: [tycho-user] [Maven & Eclipse]
Always the dependency issue … the same with your “mvn help:effective-pom"
- pouet.product has a dependency on my pouet.product.feature (without
this dependency no launcher icons, no update site… the product doen’t have
my branding)
- pouet.product.feature has a dependency on my pouet.product (of
course because the feature references the plugin which contains the product)
- the parent Pom calls the two modules
<modules>
<module>../pouet.product</module>
<module>../pouet.product.feature</module>
</modules>
With the Eclipse Product export wizard mechanism no problem, the product is well generated.
[ERROR] Software being installed: pouet.product.feature.feature.group 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product.feature.feature.group
1.6.0.qualifier requires pouet.product 0.0.0' but it could not be found
[ERROR]
It’s not a problem of version (pouet.product 0.0.0 => I’ve tried with 1.6.0
with 1.6.0.qualifier…).
I thing Maven doesn’t manager the cross dependency …
Any idea?
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or unsubscribe from
this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Nick Boldt :: Productization Lead :: JBoss Tools & Dev Studio :: Red Hat, Inc.
http://nick.divbyzero.com
Christelle BURGUERA
2016-01-12 08:18:24 UTC
Permalink
Hi Nick,
Many thank, I'll have a look.

But I've question : Why do you do a US for a product ?
Chris


-----Original Message-----
From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Nick Boldt
Sent: Monday, January 11, 2016 9:28 PM
To: Tycho user list
Subject: Re: [tycho-user] [Maven & Eclipse]

In Red Hat JBoss Developer Studio, we do this:

a) define the branding plugin
b) define a feature that contains that plugin
c) define a .product which uses the plugin, and includes the feature
d) define an update site which includes & builds the .product

So we have 4 poms, with no circular dependency:

* root pom.xml (simple entry point to build the child modules in plugins, features, and site via a single reactor)
* plugins/pom.xml
* features/pom.xml
* site/pom.xml (which also builds the .product)

This code is available to peruse here:

https://developers.redhat.com/download-manager/file/jboss-devstudio-9.0.0.GA-source.zip
Post by Christelle BURGUERA
Hello,
I really don’t understand what it’s wrong …
I tried to do my product with plugins and not features to put only the
product module (<module>../pouet.product</module>) to not have the
cross dependency
I need to put the pouet.product in the “Dependencies” under the
.product, without the export doesn’t contain my branding.
[ERROR] Failed to execute goal
org.eclipse.tycho:tycho-p2-publisher-plugin:0.19.0:publish-products
(default-publish-products) on project pouet.product: Exception while
publishing product C:\pouet.product\pouet.product.product: publishing
result: [Included element pouet.product 0.0.0 is missing. Cannot
determine filter for requirement to this element.; The features
specified in the product definition are ignored; verify the value of the 'type' or
'useFeatures' attribute. ] -> [Help 1]
Maven parent who call
Plugin with product (based on features for the Product Definition)
Feature
???
For information I’m under Luna and I use Tycho 0.19.0.
Many thank !
Christelle
From: Christelle BURGUERA
Sent: Friday, January 08, 2016 2:01 PM
Subject: RE: [tycho-user] [Maven & Eclipse]
Always the dependency issue … the same with your “mvn help:effective-pom"
- pouet.product has a dependency on my pouet.product.feature (without
this dependency no launcher icons, no update site… the product doen’t
have my branding)
- pouet.product.feature has a dependency on my pouet.product (of
course because the feature references the plugin which contains the product)
- the parent Pom calls the two modules
<modules>
<module>../pouet.product</module>
<module>../pouet.product.feature</module>
</modules>
With the Eclipse Product export wizard mechanism no problem, the product is well generated.
[ERROR] Software being installed: pouet.product.feature.feature.group 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product.feature.feature.group
1.6.0.qualifier requires pouet.product 0.0.0' but it could not be found
[ERROR]
It’s not a problem of version (pouet.product 0.0.0 => I’ve tried with
1.6.0 with 1.6.0.qualifier…).
I thing Maven doesn’t manager the cross dependency …
Any idea?
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or
unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Nick Boldt :: Productization Lead :: JBoss Tools & Dev Studio :: Red Hat, Inc.
http://nick.divbyzero.com
_______________________________________________
tycho-user mailing list
tycho-***@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from this list, visit https://dev.eclipse.org/mailman/listinfo/tycho-user
Christelle BURGUERA
2016-01-12 14:07:29 UTC
Permalink
Hi Nick, Hi All,

I download your source and I was inspired by what you did :
- root pom.xml that references 3 modules (to build a plugin, a feature and a product) :
- pom.xml that references the module plugin/pom.xml (eclipse-plugin) a plugin where is the branding
- pom.xml that references the module feature/pom.xml (eclipse-feature) a feature that include the plugin below (Plug-ins and Fragments)
- pom.xml (eclipse-repository), where is the .product

I've an error with the maven install :
[ERROR] Cannot resolve project dependencies:
[ERROR] Software being installed: pouet.product.product 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product 1.6.0.qualifier requires 'bundle org.eclipse.ui 3.106.1' but it could not be found

Of course, on my plugin where is the branding, I've added lot of required Plugins like org.eclipse.ui (the first one) ...
I don't understand why I've this error !!!

Do you have an idea ?
Thank you

Christelle

-----Original Message-----
From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Nick Boldt
Sent: Monday, January 11, 2016 9:28 PM
To: Tycho user list
Subject: Re: [tycho-user] [Maven & Eclipse]

In Red Hat JBoss Developer Studio, we do this:

a) define the branding plugin
b) define a feature that contains that plugin
c) define a .product which uses the plugin, and includes the feature
d) define an update site which includes & builds the .product

So we have 4 poms, with no circular dependency:

* root pom.xml (simple entry point to build the child modules in plugins, features, and site via a single reactor)
* plugins/pom.xml
* features/pom.xml
* site/pom.xml (which also builds the .product)

This code is available to peruse here:

https://developers.redhat.com/download-manager/file/jboss-devstudio-9.0.0.GA-source.zip
Post by Christelle BURGUERA
Hello,
I really don’t understand what it’s wrong …
I tried to do my product with plugins and not features to put only the
product module (<module>../pouet.product</module>) to not have the
cross dependency
I need to put the pouet.product in the “Dependencies” under the
.product, without the export doesn’t contain my branding.
[ERROR] Failed to execute goal
org.eclipse.tycho:tycho-p2-publisher-plugin:0.19.0:publish-products
(default-publish-products) on project pouet.product: Exception while
publishing product C:\pouet.product\pouet.product.product: publishing
result: [Included element pouet.product 0.0.0 is missing. Cannot
determine filter for requirement to this element.; The features
specified in the product definition are ignored; verify the value of the 'type' or
'useFeatures' attribute. ] -> [Help 1]
Maven parent who call
Plugin with product (based on features for the Product Definition)
Feature
???
For information I’m under Luna and I use Tycho 0.19.0.
Many thank !
Christelle
From: Christelle BURGUERA
Sent: Friday, January 08, 2016 2:01 PM
Subject: RE: [tycho-user] [Maven & Eclipse]
Always the dependency issue … the same with your “mvn help:effective-pom"
- pouet.product has a dependency on my pouet.product.feature (without
this dependency no launcher icons, no update site… the product doen’t
have my branding)
- pouet.product.feature has a dependency on my pouet.product (of
course because the feature references the plugin which contains the product)
- the parent Pom calls the two modules
<modules>
<module>../pouet.product</module>
<module>../pouet.product.feature</module>
</modules>
With the Eclipse Product export wizard mechanism no problem, the product is well generated.
[ERROR] Software being installed: pouet.product.feature.feature.group 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product.feature.feature.group
1.6.0.qualifier requires pouet.product 0.0.0' but it could not be found
[ERROR]
It’s not a problem of version (pouet.product 0.0.0 => I’ve tried with
1.6.0 with 1.6.0.qualifier…).
I thing Maven doesn’t manager the cross dependency …
Any idea?
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or
unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Nick Boldt :: Productization Lead :: JBoss Tools & Dev Studio :: Red Hat, Inc.
http://nick.divbyzero.com
_______________________________________________
tycho-user mailing list
tycho-***@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from this list, visit https://dev.eclipse.org/mailman/listinfo/tycho-user
Mickael Istria
2016-01-12 14:09:38 UTC
Permalink
Post by Christelle BURGUERA
Hi Nick, Hi All,
- pom.xml that references the module plugin/pom.xml (eclipse-plugin) a plugin where is the branding
- pom.xml that references the module feature/pom.xml (eclipse-feature) a feature that include the plugin below (Plug-ins and Fragments)
- pom.xml (eclipse-repository), where is the .product
[ERROR] Software being installed: pouet.product.product 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product 1.6.0.qualifier requires 'bundle org.eclipse.ui 3.106.1' but it could not be found
Could it be the version of the bundle that's too restrictive in
pouet.product compared to what's available in your TP? Try 0.0.0.
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat <http://www.jboss.org/tools>
My blog <http://mickaelistria.wordpress.com> - My Tweets
<http://twitter.com/mickaelistria>
Christelle BURGUERA
2016-01-12 14:11:36 UTC
Permalink
I already try withou version, Tycho but 0.0.0 
 but no change 

Error will be : Missing requirement: pouet.product 1.6.0.qualifier requires 'bundle org.eclipse.ui 0.0.0' but it could

From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Mickael Istria
Sent: Tuesday, January 12, 2016 3:10 PM
To: tycho-***@eclipse.org
Subject: Re: [tycho-user] [Maven & Eclipse]

On 01/12/2016 03:07 PM, Christelle BURGUERA wrote:

Hi Nick, Hi All,



I download your source and I was inspired by what you did :

- root pom.xml that references 3 modules (to build a plugin, a feature and a product) :

- pom.xml that references the module plugin/pom.xml (eclipse-plugin) a plugin where is the branding

- pom.xml that references the module feature/pom.xml (eclipse-feature) a feature that include the plugin below (Plug-ins and Fragments)

- pom.xml (eclipse-repository), where is the .product



I've an error with the maven install :

[ERROR] Cannot resolve project dependencies:

[ERROR] Software being installed: pouet.product.product 1.6.0.qualifier

[ERROR] Missing requirement: pouet.product 1.6.0.qualifier requires 'bundle org.eclipse.ui 3.106.1' but it could not be found


Could it be the version of the bundle that's too restrictive in pouet.product compared to what's available in your TP? Try 0.0.0.
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat<http://www.jboss.org/tools>
My blog<http://mickaelistria.wordpress.com> - My Tweets<http://twitter.com/mickaelistria>
Christelle BURGUERA
2016-01-12 15:00:51 UTC
Permalink
Is it possible there is an issue with the download process ???
I put –X to have the debug trace and I’ve this warning :
[WARNING] Could not transfer metadata com.st.system.workbench:Maven_SW4STM32:1.6.0-SNAPSHOT/maven-metadata.xml from/to eclipse-luna (http://download.eclipse.org/releases/luna): No connector available to access repository eclipse-luna (http://download.eclipse.org/releases/luna) of type p2 using the available factories AsyncRepositoryConnectorFactory, WagonRepositoryConnectorFactory

From: Christelle BURGUERA
Sent: Tuesday, January 12, 2016 3:12 PM
To: tycho-***@eclipse.org
Subject: RE: [tycho-user] [Maven & Eclipse]

I already try withou version, Tycho but 0.0.0 
 but no change 

Error will be : Missing requirement: pouet.product 1.6.0.qualifier requires 'bundle org.eclipse.ui 0.0.0' but it could

From: tycho-user-***@eclipse.org<mailto:tycho-user-***@eclipse.org> [mailto:tycho-user-***@eclipse.org] On Behalf Of Mickael Istria
Sent: Tuesday, January 12, 2016 3:10 PM
To: tycho-***@eclipse.org<mailto:tycho-***@eclipse.org>
Subject: Re: [tycho-user] [Maven & Eclipse]

On 01/12/2016 03:07 PM, Christelle BURGUERA wrote:

Hi Nick, Hi All,



I download your source and I was inspired by what you did :

- root pom.xml that references 3 modules (to build a plugin, a feature and a product) :

- pom.xml that references the module plugin/pom.xml (eclipse-plugin) a plugin where is the branding

- pom.xml that references the module feature/pom.xml (eclipse-feature) a feature that include the plugin below (Plug-ins and Fragments)

- pom.xml (eclipse-repository), where is the .product



I've an error with the maven install :

[ERROR] Cannot resolve project dependencies:

[ERROR] Software being installed: pouet.product.product 1.6.0.qualifier

[ERROR] Missing requirement: pouet.product 1.6.0.qualifier requires 'bundle org.eclipse.ui 3.106.1' but it could not be found


Could it be the version of the bundle that's too restrictive in pouet.product compared to what's available in your TP? Try 0.0.0.
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat<http://www.jboss.org/tools>
My blog<http://mickaelistria.wordpress.com> - My Tweets<http://twitter.com/mickaelistria>
Nick Boldt
2016-01-12 15:14:08 UTC
Permalink
I would guess you're having a problem resolving things on eclipse.org
or one of its mirrors. There are 3 different versions of
org.eclipse.ui in the Luna site, so you should be able to see at least
one of them.

It's because of sporadic p2 metadata/artifact resolution failures
pulling from eclipse.org mirrors that we mirror ALL the stuff we need
in our target platform to our own mirror on download.jboss.org so we
can fully control what's there and how it's built.

Just to see if it's a network/mirror failure or something else (ie., a
problem in your code), you could try using our mirror *temporarily* as
a replacement for your ref to
http://download.eclipse.org/releases/luna

http://download.jboss.org/jbosstools/updates/requirements/luna/201406120900-RC4/
(Luna R)
http://download.jboss.org/jbosstools/updates/requirements/luna/201502190900-SR2-RC4/
(Luna SR2)

Please don't rely on this site in your builds, however, as we may at
some point remove it.

Note also regarding the warning, "No connector available to access repository":

https://dev.eclipse.org/mhonarc/lists/tycho-user/msg06446.html

On Tue, Jan 12, 2016 at 10:00 AM, Christelle BURGUERA
Post by Christelle BURGUERA
Is it possible there is an issue with the download process ???
[WARNING] Could not transfer metadata
com.st.system.workbench:Maven_SW4STM32:1.6.0-SNAPSHOT/maven-metadata.xml
from/to eclipse-luna (http://download.eclipse.org/releases/luna): No
connector available to access repository eclipse-luna
(http://download.eclipse.org/releases/luna) of type p2 using the available
factories AsyncRepositoryConnectorFactory, WagonRepositoryConnectorFactory
From: Christelle BURGUERA
Sent: Tuesday, January 12, 2016 3:12 PM
Subject: RE: [tycho-user] [Maven & Eclipse]
I already try withou version, Tycho but 0.0.0 … but no change …
Error will be : Missing requirement: pouet.product 1.6.0.qualifier requires
'bundle org.eclipse.ui 0.0.0' but it could
On Behalf Of Mickael Istria
Sent: Tuesday, January 12, 2016 3:10 PM
Subject: Re: [tycho-user] [Maven & Eclipse]
Hi Nick, Hi All,
- pom.xml that references the module plugin/pom.xml (eclipse-plugin) a
plugin where is the branding
- pom.xml that references the module feature/pom.xml (eclipse-feature) a
feature that include the plugin below (Plug-ins and Fragments)
- pom.xml (eclipse-repository), where is the .product
[ERROR] Software being installed: pouet.product.product 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product 1.6.0.qualifier requires
'bundle org.eclipse.ui 3.106.1' but it could not be found
Could it be the version of the bundle that's too restrictive in
pouet.product compared to what's available in your TP? Try 0.0.0.
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat
My blog - My Tweets
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or unsubscribe from
this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Nick Boldt :: Productization Lead :: JBoss Tools & Dev Studio :: Red Hat, Inc.
http://nick.divbyzero.com
Christelle BURGUERA
2016-01-12 15:41:18 UTC
Permalink
I've change the proxy, and I've no more this warning ... but always the error :
[ERROR] Cannot resolve project dependencies:
[ERROR] Software being installed: pouet.product 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product 1.6.0.qualifier requires 'bundle org.eclipse.ui 0.0.0' but it could not be found

:(

-----Original Message-----
From: tycho-user-***@eclipse.org [mailto:tycho-user-***@eclipse.org] On Behalf Of Nick Boldt
Sent: Tuesday, January 12, 2016 4:14 PM
To: Tycho user list
Subject: Re: [tycho-user] [Maven & Eclipse]

I would guess you're having a problem resolving things on eclipse.org or one of its mirrors. There are 3 different versions of org.eclipse.ui in the Luna site, so you should be able to see at least one of them.

It's because of sporadic p2 metadata/artifact resolution failures pulling from eclipse.org mirrors that we mirror ALL the stuff we need in our target platform to our own mirror on download.jboss.org so we can fully control what's there and how it's built.

Just to see if it's a network/mirror failure or something else (ie., a problem in your code), you could try using our mirror *temporarily* as a replacement for your ref to http://download.eclipse.org/releases/luna

http://download.jboss.org/jbosstools/updates/requirements/luna/201406120900-RC4/
(Luna R)
http://download.jboss.org/jbosstools/updates/requirements/luna/201502190900-SR2-RC4/
(Luna SR2)

Please don't rely on this site in your builds, however, as we may at some point remove it.

Note also regarding the warning, "No connector available to access repository":

https://dev.eclipse.org/mhonarc/lists/tycho-user/msg06446.html
Post by Christelle BURGUERA
Is it possible there is an issue with the download process ???
[WARNING] Could not transfer metadata
com.st.system.workbench:Maven_SW4STM32:1.6.0-SNAPSHOT/maven-metadata.x
No connector available to access repository eclipse-luna
(http://download.eclipse.org/releases/luna) of type p2 using the
available factories AsyncRepositoryConnectorFactory,
WagonRepositoryConnectorFactory
From: Christelle BURGUERA
Sent: Tuesday, January 12, 2016 3:12 PM
Subject: RE: [tycho-user] [Maven & Eclipse]
I already try withou version, Tycho but 0.0.0 … but no change …
Error will be : Missing requirement: pouet.product 1.6.0.qualifier
requires 'bundle org.eclipse.ui 0.0.0' but it could
On Behalf Of Mickael Istria
Sent: Tuesday, January 12, 2016 3:10 PM
Subject: Re: [tycho-user] [Maven & Eclipse]
Hi Nick, Hi All,
- pom.xml that references the module plugin/pom.xml (eclipse-plugin)
a plugin where is the branding
- pom.xml that references the module feature/pom.xml (eclipse-feature)
a feature that include the plugin below (Plug-ins and Fragments)
- pom.xml (eclipse-repository), where is the .product
[ERROR] Software being installed: pouet.product.product 1.6.0.qualifier
[ERROR] Missing requirement: pouet.product 1.6.0.qualifier requires
'bundle org.eclipse.ui 3.106.1' but it could not be found
Could it be the version of the bundle that's too restrictive in
pouet.product compared to what's available in your TP? Try 0.0.0.
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat My blog - My Tweets
_______________________________________________
tycho-user mailing list
To change your delivery options, retrieve your password, or unsubscribe from
this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user
--
Nick Boldt :: Productization Lead :: JBoss Tools & Dev Studio :: Red Hat, Inc.
http://nick.divbyzero.com
_______________________________________________
tycho-user mailing list
tycho-***@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user

Continue reading on narkive:
Loading...